Download site for latest JRE 6 for AIX 5.3

I can only find the path and site to download the JDK.Can someone help me find the latest JRE 6 for AIX? ...

performance problem with JRE 6 on both AIX and Windows

My program on IBM JRE 6 runs much slower than on IBM JRE 5 (or Sun's JRE 6).On AIX with JRE 1.5 SR9-0 it runs smoothly so as on Windows with JRE 1.5 (from IBM development package for Eclipse Version 211).On top of that the same program running on Sun's JRE 6 on Windows runs fine.Example figures (exe ...

Minimum AIX level supported

I've posted this in another forum, but I think it is the wrong one.Does anyone know the answer to this: I found the latest JRE version "Minimum AIX level supported" for each AIX version in the following link:http://www-128.ibm.com/developerworks/java/jdk/aix/service.htmlHowever - I want to know the ...

Web Start with Java 5 on AIX - Bad Installation Error

I am getting this error while trying to run the javaws command on AIX:Java Web Start splash screen process exiting ...Bad installation: JAVAWS_HOME not setSearching on forums got some possible solutions, but none worked so far. I tried already:-Exporting JAVAWS_HOME-Verified JAVA_HOME was defined-Ge ...

Java bean Introspection resulting inconsistent output in IBM Java 1.6

we have an application which is currently running properly on (IBM Java 5.0 + Oracle 10.1.3.3 App Server + AIX 5.3) environment.Now we are upgrading the application to run on Java 1.6. As a part of that we tested the application on (SUN Java 6 + Oracle 10.1.3.5 App Server + Windows) environment. App ...

verify JRE on AIX 5.3

on my 5.3 box I have a BAAN 5 and Oracle 10.2.0.1. Since many of the Oracle, BAAN also, processes use the Java codes, So i am wondering how to verify the JRE on the system? Does the AIX 5.3 come with its own JRE or may come from Oracle? Because yesteray one of the JAVA daemon for the Oracle stopped, ...

JRE 1.3 on AIX 4.3.3 gives SIGSEGV 11 (*) segmentation violation

I'm using JRE 1.3 on AIX 4.3.3 to run my application. I tried to open some of the dialog and the application crashed, which gave me this messages SIGSEGV 11 (*) segmentation violationsi_signo 11: SIGSEGV: (*) segmentation violationsi_errno [0]: Error 0si_code 50: SEGV_MAPERR addr: 0x6974697Bstackpoi ...

AIX 1.5 jre not killing child processes

In upgrading the jre from 1.4 to 1.5 on AIX, it appears that child processes are not being killed when the "kill" command is issued to the parent process pid. The pids of the child processes go from having the correct parent pid to having a parent pid of "1". How can I get the system to kill the chi ...

IPv4 by default for IBM AIX JRE 1.4.2

I am trying to change the default configuration for the JVM setting for IPv4 on IBM JRE 1.4.2 which set to IPv6is there anyway that i could change the parameters without having a -D option in the applicationhere is my JRE buildjava version "1.4.2"Java(TM) 2 Runtime Environment, Standard Edition (bui ...

Difference in XSLT Behaviour between IBM Windows JRE and AIX JRE 1.4.2

HiA Java application that that I have developed and tested on a Windows platform using the IBM 142 JRE has been moved to AIX using the IBM 142 JRE. The application uses Java extension classes with XSLT, which work fine under the Windows JRE, but fail (no errors but do not return values) on the IBM A ...

Eclipse with IBM JRE 1.5 on AIX 5.3 fails->JVM Terminated Exit code=160

I have installed the IBM version of the Eclipse SDK 3.2.2 (eclipse-SDK-3.2.2-aix-motif.zip) onto our AIX 5.3-003 box. When I start Eclipse, I receive the splash screen, then the prompt to select my workspace location, but soon after, I received the error "JVM Terminated Exit code=160".Can anyone she ...

AIX JRE, java.beans.XMLDecoder implementation question

HiIs XMLDecoder safe to be used in multithreaded environment ? ( Or even if 2 separate copies of XMLDecoder can be used at once ? )My threads don't share any objects. Most of the time everything works fine, but sometimes after deserialization I'm getting some nulls in deserialized objects. Log says ...

AIX JRE: -client / -version options?

Why the -client and -server option available with JRE on Solaris is not supported on AIX? Does it make sense to talk about "client" version and "server" version within the AIX JDK? ...

Multiple JRE on AIX 5.1 ML3

I was asked to install JRE/JDK 1.4.1 on a p690 LPAR (not that it matters...) with JRE 1.3.0 already installed. The O.S. is AIX 5.1ML3.My understanding is that if I try to do this using installp, the installation will either fail or will step on the existing 1.3.0 JRE. If I don't use installp, I can ...

How to get Unlimited Cryptography Jars of 1.4.2 JRE for AIX

We are getting this exception -java.lang.ExceptionInInitializerErrorat javax.crypto.Cipher.a(Unknown Source)at javax.crypto.Cipher.getInstance(Unknown Source)at iaik.security.provider.IAIK.a(Unknown Source)at iaik.security.provider.IAIK.addAsJDK14Provider(Unknown Source)at iaik.security.provider.IAI ...

Problems with IBM JRE on AIX with XSL Java Extensions

HiI've developed a Java application that uses Java extensions within XSL transforms. On Windows, all works. Moving the application to AIX, the Java extensions are not working - I simply see nothing returned in the transformed XML when I call a Java static function I have written. No errors are throw ...

JRE 1.6 for AIX

I am new to AIX and working in AIX 5.3(32-bit) and I want to install the JRE1.6 in the machine.So I downloaded the Base Java6.sdk from IBM web-site URLWhen I am trying to install it,I am getting the error given below--MISSING REQUISITES: The following filesets are required by one or more of the sele ...

JRE 1.6 for AIX

I am new to AIX and working in AIX 5.3(32-bit) and I want to install the JRE1.6 in the machine.So I downloaded the Base Java6.sdk from IBM web-site URLWhen I am trying to install it,I am getting the error given below--MISSING REQUISITES: The following filesets are required by one or more of the sele ...

How to Install JRE 1.5 on AIX without JDK

When we go to download IBM JRE we only have an option to install JDK, which contains JRE. We do not want JDK installed on our server only JRE. How do we only install IBM 1.5 JRE and not include JDK? ...

IBM JRE on AIX and Sun's implemenation of JSSE

I am using sun's default implementation of JSSE and deploying the servlet on Websphere 4.x. When I try to communicate with the setup server socket I get this exceptionClient Handshake failure java.io.IOException: There is no processto read data written to a pipe.service is not ready: Client Handshak ...

JRE 1.4.2 for AIX 5.2 64 bits - JIT bug

I have a static variable [b][i]S[/i][/b] (integer) in class [b]A[/b].I call [b]A.S[/b] from class [b]B[/b].the value of [b][i]S[/i][/b] is [b]-1000[/b].codeclass A{public static int S = -1000;} class B{public long foo(){return A.S;}}[/code]when calling [b]A.S[/b] for the first time, the value reture ...

AIX / csh Shell / navigation with backspace, arrows / history

It is my first contact to AIX, it is a SAP Installation. The System + SAP has been installed by other's... Root User Shell is ok, using /usr/bin/ksh and everything is working well, the SAP User is defined to use /usr/bin/csh (no Change possible..)Under the SAP User, the Shell is extremly boring: It ...

JNI program work with jdk 5 but not jdk6 on aix 5.3

My JNI program work with jdk 5 but not jdk6 on aix 5.3.i.e. I compiled & tested my program with jdk 5 and it worked.Then with the same files & directory, I run jdk6 (I installed bothjdk5 & 6) and it failed.Why?Please help to fix this problem.Thanks.jdk5 is ok:$ /usr/java5_64/jre/bin/java ...

aix enviroment problem?

I having problem to set up enviroment for aix 5.3 server. whenever i execute do env or printenv no output return .I know something missing which causing this but after googling still cannot manage to solve it.I alos compared with other servers and founded evertyhing looks alike but some how its not ...

db2 8.1 under AIX 5.1 give starnge behavier

just wonder if anyone tested DB2 V8.1 FP4 under AIX 5.1 ML 5 ?knowing that i tested DB2 V8.1 FP4 under Linux works fine !Mainly i got 2 problems :1. while using Xmanager from windowns machine to access the AIX machine, tyring to start up the db2cc i have this error :[IBM] JDBC java.lang.UnsatisfiedL ...

Deploying an app on AIX using java webstart (jnlp)

I'm tearing my hair out trying to get an application deployed using Webstart.I'm using AIX 6.1 with the latest fix pack 6100-05. Installed is /usr/java6_64, Mozilla Firefox(64) 3.5.2 and Mozila 1.7.13.1I know the application works because I've made it run on AIX with EclipseAlso, if I point my windo ...

IBM(R) Distributed Debugger 9.2 vs IBM Debugger for AIX V6.0

We used to use IBM(R) Distributed Debugger on our AIX test machine.The information is as below:<hr />idebug.client.extras 9.2.9.0 COMMITTED Debugger Interpreted Engineidebug.client.gui 9.2.9.0 COMMITTED Debugger Graphical Useridebug.client.olt 9.2.9.0 COMMITTED Object Level Trace Vieweridebug. ...

lparmon not running on AIX 5.3

i tried to run the LPAR Monitoring on AIX 5.3:+ cd /tmp+ export JAVAHOME=/usr/java130/jre+ export LPARMONHOME=/tmp+ export LANG=en_US+ export JAVALANG=en_US+ export CLASSPATH=/usr/java130/jre/lib/rt.jar:/usr/java130/jre/lib/tools.jar:/tmp/lparmon/lparmon.jar:.+ /usr/java130/jre/bin/java com/ibm/lpar ...

db2setup failed on AIX 6.1 [Db2 9.7 + AIX 6.1]

I have issue with installing db2 on my new server. Setup fail after 2-3 second at the start. In /tmp i found db2setup.errQuote: Originally Posted by oslevel -s 6100-05-02-1034 Quote: Originally Posted by Db2 version setup 9.7.0.0 Can you advise me something? Thanks in advance!db2setup.errUnhandled e ...

IBM Director 6.1 - problem of java performances because of AIX 6.1 timezone

Just a post to explain the problem I just encountered, if it could help others ...I installed IBM System Director onto AIX 6.1 TL2 SP2 (6100-02-02-0849) and also the Common AIX agent on two lpars using also AIX 6.1 TL2 SP2.The installation of ISD took a long time.The manual installation of the Commo ...

Configuring the database application on AIX 6.1

I am having some troubles Configuring the the Default Database on AIX 6.1See below for the screen output.root@supdir1/root> . /opt/ibm/director/bin/cfgdbcmd.sh -rspfile /opt/ibm/director/proddata/cfgdbcmd.rsp -dbAdmin director -dbAdminPW dire>which: 0652-141 There is no -ksh in /usr/bin /etc / ...

No Access to AIX Common agent system

I am trying to manage two AIX machines that are running the common agent.root@AIX_I:/opt/ibm/director/agent/bin#ksh lwistatus.shwhich: 0652-141 There is no lwistatus.sh in /usr/bin /etc /usr/sbin /usr/ucb /usr/bin/X11 /sbin /usr/java14/jre/bin /usr/java14/bin.which: 0652-141 There is no lwistatus.sh ...

DB2 8.2 for AIX db2cc will not start

I have just installed DB2 8.2 on a brand new AIX 5.2 system. The install was successful, but when running the control center for the first time, I get this error:Exception in thread "main" java.lang.UnsatisfiedLinkError: Can't find library db2jcmn (libdb2jcmn.a or .so) in sun.boot.library.path or ja ...

AIX: ORA-27101: shared memory realm does not exist

I've upgraded 8.1.6 to 8.1.7.and now sqlplus returns the following:kia:/oracle/oracle8i/8.1.7/bin> sqlplus system/managerSQL*Plus: Release 8.1.7.0.0 - Production on Thu Jul 10 22:21:02 2003(c) Copyright 2000 Oracle Corporation. All rights reserved.ERROR:ORA-01034: ORACLE not availableORA-27101: s ...

Invalid data conversion using cp037 and IICE 8.4 running under JRE 1.5

I have a custom connector that is currently running in direct mode within IICE 8.4 and under WAS 6.0/JRE 1.4.. on an AIX 5.2 system. This connector receives EBCDIC data from a mainframe system. I then moved this connector to a Linux system running WAS 6.1/JRE 1.5.... When the following statement is ...

DSAC V1.1.2 GA AIX

when I try to install the new Version from DSAC on AIX, I didn't found thelogs files after installation the IBM_DSAC_V1.1.2_GA_AIX_bin.root@r18l12 [/db2inst/DSAC]>./IBM_DSAC_V1.1.2_GA_AIX_ppc_64.binPreparing to install...Extracting the JRE from the installer archive...Unpacking the JRE...Extracti ...

OmniFind 8.4 installation on 64-bit AIX

I'm getting the following error when I starting the OmniFind 8.4 installation on 64-bit AIX machine:"Error extracting inner launcher. Archive may be corrupt. Failed to launch the application."The machine is at technology level 7 with service pack 1:oslevel -s5300-07-01-0748Before installing SP1, I g ...

Java client on JA_JP AIX

Trying to run a Java client (heavyweight) on a Japanese language pack enabled AIX machine, using IBM JRE 1.3.1, will consistently result in this error within minutes of initially successful operation:Wed Dec 11 14:07:14 2002SIGSEGV received at 0xd102c4a8 in /usr/lib/libXt.a. Processing terminated.Cu ...

JNI on AIX -- SIGILL problem.

We have received some c code from our client which we have to integrate in our java code. I have written a java class with some native methods. And a c program which is called from java using JNI and this c program calls the functions from the code provided by our client. Taking togather my own c pr ...

JVM hang on GC on AIX 4.3.3

I am running following version of jre....java version "1.3.1" Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1) Classic VM (build 1.3.1, J2RE 1.3.1 IBM AIX build ca131ifx-20040721a SR7P (JIT enabled: jitc)) There were several GC hang fixes in SR7P.Last lines of debug...<AF151: Alloca ...

jre1.4.2 work on AIX 4.3.3?

Wondering if jre 1.4.2 works on AIX 4.3.3. If so, I'm getting "Could not create the Java virtual machine." and am in need of some help. ...

JRE JIT bug

I've posted this subject to "XML and Java Technology" forum but I got no response, so I am trying here. I get exception while using JDOM:root cause: org.jdom.IllegalNameException: The name "name" is not legal for JDOM/XML attributes: Attribute names cannot contain colons.at org.jdom.Attribute.setNam ...

AIX JVM intermittent crash

We have an application that is experiencing intermittent crashes - I have obtained javacore text output from 2 of those crashes - and both point to problems in the libxhpi.a load module in the JRE. We are gettting SIGSEGV's in this load module - both at the same address 0xd0100b18.The JVM level is A ...

Endorsed Standards Override for AIX SDK 1.4 with xalan-j

[b]Question overview[/b]Does the IBM Java SDK 1.4 for AIX 5.1 support the endorsed standards override mechanism and if so, how does one exploit it. If not, is there a way of overriding APIs that are included in the reference implementation provided by IBM?[b]Question details[/b]I am developing a jav ...

Deployment of JRE 1.4.2 without SDK

Can anyone confirm the normal mechanism for deploying just the JRE to a production service (without the SDK naturally). The JRE readme states "The Runtime Environment code is provided so that application vendors could bundle and ship it with their applications. For all other purposes the IBM (R) 32- ...

AIX 5.1 ML9 and Java : java.lang.UnsatisfiedLinkError : ENOEXEC

Can anyone help me with this puzzling question.I have a Java application running on Java 1.4.1OS is AIX 5.1 ML9.When I run the application I get : java.lang.UnsatisfiedLinkError: /opt/errm/profiler/_jvm/jre/bin/libawt.a: load ENOEXEC on shared library(s) /opt/errm/profiler/_jvm/jre/bin/libawt.a /usr ...

SDK1.4.2 on AIX 5.2: JNI_CreateJavaVM error: Can't find class java.lang.NoClassDefFoundError.

Can anyone help to look at the JNI issue?Thanks in advance!Try to test the JNI invocation API using the examples from:http://www-128.ibm.com/developerworks/linux/library/l-pow-jniexamples.htmlThe compilation is OK, however, the "invoke" program crashed with messages:codeCan't find class java.lang.No ...

load ENOEXEC on shared library(s) - problem under WebSphere Application Server v6 on AIX 5.3

I am trying to compile and use map server on AIX 5.3 (see http://mapserver.gis.umn.edu/docs/howto/compiling_on_unix/view). The compiling has been fairly successful and, as part or the compilation process, a mapscript.jar file is produced (the source is generated by SWIG). The java objects within thi ...

After IBM JRE 1.4.2.51 upgrade, the following error message we got:java.lang.NoClassDefFoundError:

We've just upgraded from AIX 5.2 to AIX 5.3 and installed IBM JRE 1.4.2.0 (64 bit)then upgraded to 1.4.2.51 (64 bit). Since this upgrade we got the following error message in Oracle financials app which are using this Java:java.lang.NoClassDefFoundError:javax/jms/JMSExceptionWhat can be the problem? ...

After IBM JRE 1.4.2.51 upgrade, the following error message we got:java.lang.NoClassDefFoundError:

We've just upgraded from AIX 5.2 to AIX 5.3 and installed IBM JRE 1.4.2.0 (64 bit)then upgraded to 1.4.2.51 (64 bit). Since this upgrade we got the following error message in Oracle financials app which are using this Java:java.lang.NoClassDefFoundError:javax/jms/JMSExceptionWhat can be the problem? ...