gtk+ configure error: glib-compile-schemas not found

I've been installing a seemingly endless list of tools and libraries since deciding to update the GTK+ libraries that I'm using on a Red Hat machine. Seems like everytime I think I've got just one more package to install to meet GTK's prerequisites, I discover that there are 3 things that that packa ...

Ubuntu glib-compile-schemas in lucid

When compiling many apps on lucid, configure bombs when glib-compile-schemas is not found. (I say many because of all the google hits on people asking about this error.) It seems that glib-compile-schemas is not included in the glib2.0 packages for lucid. In my case I'm trying to build a later versi ...

Ubuntu GLib compile issue

I'm working on a program right now that uses GLib for key-value files to configure the program. When I try to compile it via a Makefile it cannot find the various GLib headers located in /usr/include/glib-2.0/glib/. The snippet of code from the Makefile that shoud do it is:%.o: %.c $(HEADERS)$(SUMMA ...

PHP Re-Compile with Apache RPM Install?

The version of Apache was installed by RPM...Current version of PHP was also installed by RPM...however MySQL was not...It is six of one/half dozen of the other...when build PHP from source, I can build the path-to-mysql in but not the path to apache (is was installed from RPM)...PHP from RPM can se ...

PHP Re-Compile with Apache RPM Install?

The version of Apache was installed by RPM...Current version of PHP was also installed by RPM...however MySQL was not... It is six of one/half dozen of the other...when build PHP from source, I can build the path-to-mysql in but not the path to apache (is was installed from RPM)...PHP from RPM can s ...

mysql-workbench x86_64 compile from src rpm

Since there is no pre-packaged Mandriva x86_64 rpm for mysql-workbench 5.1.16, I tried compiling one from the source rpm available here Unfortunately, the compilation (rpmbuild -ba ./mysql-workbench.spec.in ) fails with several errors about pthread_rwlock: g++ -shared -nostdlib /usr/lib/gcc/x86_64-m ...

Ubuntu can't finish ./compile command

I'm using Ubuntu 10.04 with gnome 2.3. g++, gcc, built-essentials are installed. I want to install gtkpod program. The version in the repository is quite old. That's why I decided to build it by myself. I downloaded the archive, unpacked it and changed the folder. When I did the command "./conf ...

Ubuntu Problem upgrading! get some error code

I have Lucid installed on my system. . have also installed gnome shell through the ricotz repository. today when the system asked me to upgrade and I went ahead with it.. I get an errorVivek@vivek-desktop:~$ sudo apt-get upgradeReading package lists... DoneBuilding dependency tree Reading state info ...

Ubuntu flush drive unvisible

After power blackout Ubuntu10.04 doest not see flash drive.I meant it does not mount.Any suggestions.I ran $ cat /proc/scsi/scsiAttached devices:Host: scsi0 Channel: 00 Id: 00 Lun: 00Vendor: ATA Model: WDC WD400AB-00BV Rev: 21.0Type: Direct-Access ANSI SCSI revision: 05Host: scsi1 Channel: 00 Id: 00 ...

Ubuntu Empathy, Pidgin: bus error

I have a weird problem with ubuntu 10.04 amd64...Both Pidgin and Empathy don't start either in shell or in the Applications menuprene@boo:~$ empathy -vEmpathy 2.30.2prene@boo:~$ empathy Bus errorprene@boo:~$ pidgin Bus errorprene@boo:~$ pidgin -vPidgin 2.6.6 (libpurple 2.6.6)prene@boo:~$ pidgin -d(0 ...

Ubuntu ./conifgure error while building Empathy

I recently wanted to build Empathy 2.31 from a source tarball (after having installed all the dependencies listed on the Empathy website).I got the following error while launching ./autogen.sh:configure: error: glib-compile-schemas not found.After some googling to try to fix this problem, I've found ...

Ubuntu Gnome 3 ~ Install extensions

I install Gnome 3 with Ubuntu 11.04 using Gotbletu's video http://www.youtube.com/watch?v=haCHS2LUH9Q by running the following commands:sudo add-apt-repository ppa:gnome3-team/gnome3sudo apt-get updatesudo apt-get dist-upgradesudo apt-get install gnome-shellsudo apt-get install gnome-sessionsudo apt ...

Ubuntu gnome-shell broken with today update

everybody. Today I updated the gnome-shell package from ricotz ppa and it gave me a bunch of errors.now I have the gnome-shell package broken and I'm not able to delete it nor with synaptic nor with apt-get purge it gives a glib compile schemas not foud exit error status 127what can I do to get rid ...

Ubuntu Building Nautilus 2.91 from source

I'm trying to build nautilus 2.91. When I run the configure script I get the following errorconfigure: error: glib-compile-schemas not found.I've checked and glib-compile-schemas exist under the /usr/lib/glib-2.0 directory. I've tried adding the directory to my path but that does not help.This is th ...

Redhat/Centos - Sybase Open Client

PLEASE HELP I'M GOING INSANE!I'm trying to install "sqsh" on my Centos 5.0 Box.It is dependant on the Sybase Open Client - CT Library(Apparently it can use FreeTDS, but I have this installed and sqsh ignores it).All I need is to install the Sybase CT Library.Where the hell can I get it fro ...

HOWTO: Setup PHP 5.2 on CentOS 5

This is an easy way to install PHP 5.2 with yum. I prefer this way because I dislike using non-official CentOS repositories.Firstly setup the CentOS development repository (Although it's a development repo, I have found no problems.)sudo nano /etc/yum.repos.d/CentOS-Testing.repoPlace this within the ...

How to update software installed from source (CentOS)

First of all, I know it's bad practice to install software from source. I did it because (1) I needed a more recent version of ImageMagick than I could find in a CentOS RPM and (2) I have never built an RPM before and wasn't up to figuring out how at the time. Now I need to update it.Can anyone sugg ...

HOWTO: Install Centos 5 to a slice

Here are the steps I used to install a fresh copy of Centos 5 onto my slice. I used a new tool developed byDebian Developer Steve Kemp called rinse to do so. It's not the most polished set of instructions but it works.As is usual for such things, I take no responsibility for any damage you do follow ...

MySQL Error 2002 - CentOS 5 - PHP 5.3.6

I apologize in advance for any ignorance with regard to posting in this forum. I know that some fora have rules for what should be posted first (system details, etc.) to help diagnose the issue. I've included information about my Linux distribution to give details about my machine as follows: BEGIN ...

rpm build error: cannot find -lstdc++

I am trying to compile a Redhat rpm.All I have changed in the SPEC file is without mysql to with mysql.however, when I do a rpm -ba I eventually get an error "/usr/bin/ld: cannot find -lstdc++"I have libstdc++3-3.0.1-3 libstdc++-3.1-0.21 libstdc++-2.96-98 installed on my system. Should I h ...

CentOS : Unable to install java

I am unable to install the jre RPM which i downloaded fron SUN website.This is the error i get: (Using CentOS)# rpm -Uvh jre-6u24-linux-i586.rpmPreparing... ########################################### [100%]package jre-1.6.0_24-fcs is already installedThis package i saw isn't present.Please help me. ...

Why I can't compile my progream ( using mysql library ) under Cygwin ?

i install mysql from sourcecode , mysql version 5.1.56 i compile using : ./configure --without-readline --without-server CFLAGS=-O2 make make install ex compile my program: gcc $(mysql_config --cflags) $(mysql_config --libs) $(mysql_config--include) test.c -o test ex error: undefined reference to `_ ...

two mysql 's problem??

i want to install two mysql in my server,one is from rpm 3.23.36 ,one is from source compile,mysql1 use rpm to install,(latin1)mysql2 use gcc compile:after install mysql1,install perl DBI,DBD-mysql./configure --prefix=/usr/local/mysql2 --with-charset=gbk --with-unix-socket-path=/usr/local/mysql2/tmp ...

rpmbuild problem

This is my first post so I'd like to say hi. This seemed the most appropriate forum but if it's not please move this thread mods. My problem is that I can't seem to be able to build an rpm from a src.rpm. Before anyone tells me to google it I did and I also searched this site but I still can't build ...

install yum and lamp

I'm trying to install VHCS control panel on my VPS server (Virtuozzo)Yum is not installed apparently[root@italkhost root]# rpm --import http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-4[root@italkhost root]# rpm -Uvh yum-2.0.4-1.noarch.rpmerror: open of yum-2.0.4-1.noarch.rpm failed: No such file ...

yum configure

install yum!but the configure I don't konw how to configure!my os is x86_64 Red Hat Enterprise Linux AS release 4please help me!!the i686 configure is:[base]name=CentOS-4.4 - Basebaseurl=http://mirror.be10.com/centos/4/os/i386/gpgcheck=1gpgkey=http://mirror.be10.co ...

esc/p to ps

i have a big problemi use succesfuly DOSEMU 1.4 for old accounting program on i386 centos 5program work well, printing is ok if i connect old esc/p epson directly on linux boxbut, is there any way (program) to convert esc/p to ps on linux ?to be clear,dosemu print esc/p -> captured into file - ...

php giving no errors, blank pages...

So some cowboy (not me I promise) was trying to do all these updates with up2date on our box (CentOS4) and it somehow pooched everything. I had to reinstall mySQL, and took the time to upgrade our version of mySQL to 5.0.37. All references to php were messed up somehow too, so I upgraded that too (P ...

Ubuntu lib-linux.so.2 dependancy

Howdy Folks. Like everyone else posting here, I've finally taken the plunge into Linux and decided on Ubuntu 6.06 LTS(long journey...Fortran>Basic>AmigaDOS>lost in Windoze black hole for too long>linux). Installation and configurtation went seamlessly and I've got a well configured LAMP ...

Ubuntu How to connect to AOL

I'm trying to help my friend set up Kubuntu. His internet connection is via AOL. Does anyone know how that can be done? I've used Pengaol in the past, but it is really old and unmaintained. It won't compile, and the RPM file (no deb available) depends on libstdc++-libc6.2-2.so.3, which I can't find ...

Ubuntu HELP Please: WiFi Thoroughly Stuffed Up by my meddling!

in an effort to demonstrate that my ambition exceeds my ability I began a process of digging around in my (working) NetworkManager and nm-applet setup.I was having intermittant link dropout and sometimes it would not reconnect despite my doing everything right according to the wiki and threads here. ...

Oracle Enterprise Service Bus + Transport SDK + Sample + Socket

I've installed OSB and I'm trying to build the sample Transport SDK.First of all , inside schemas folder I noticed that the TransportCommon.xsd is missing. So I unziped the sb-kernel-api.jar located inside installation of OSB folder and found these missing archives.Then I added to classpath the webl ...

xmlpipe: expected '<document>', got ''<sphinx:docset>'

I'm trying to get Sphinx to work with the xmlpipe2 configuration.My source is configured like below:source mysource{        type = xmlpipe2        xmlpipe_command = php /home/tim/indexer.php}When I run this I get:[root@s ...

RPM Source 4.3.3 Make Failed in CentOS

I'm using CentOS 5.5 and trying to compile RPM 4.3.3, this is required for our target board specific needs. When I did compile RPM 4.3.3's source I got the following error. How to rectify this one? error: selinux/selinux.h: No Such File or directoryWhat I have to install for selinux.h? ...

Sphinx My experience installing 1.10-beta from RPM on Centos 5

Just installed for a client and thought my experience may be helpful to others asdocumentation appears to be incomplete.cat /etc/redhat-release # Check Centos releasecd /var/brainforge/rpmwget http://www.sphinxsearch.com/downloads/sphinx-1.10-1.el5.x86_64.rpm rpm -i sphinx-1.10-1.el5.x86_64.rpm* Got ...

how to compile network adaptor source rpm

I have SUSE Linux 10.1 kernel 2.6.16.21. I copied the source RPM package for the broadcom netxtreme gigabit network adaptor and put it in the location /usr/src/linux as the instructions said. But when I try to build it it is looking in the location 2.6.16.21-0.25-smp as you can see from the stdout s ...

"rpm --install xxxx.src.rpm" does not compile or install

So I downloaded several srpm's from ftp.readhat.com (/pub/redhat/linux/enterprise/3/en/os/i386/SRPMS). When I try to install, nothing happens:# rpm --install libpng-1.2.2-16.src.rpm#We're using RedHat 3WS. I was unable to find a binary rpm, so I went for the source rpm.It seems to unpack the source ...

Unable to update my RPM database ?.I instlled the new ver of glib..but rpm is nt uptd

Installed the new ver of glib 2.8.4....Aftre that i used the command rpm -vv rebuilddb ...in rhel 4.0 Eventhough it updated the old value of glib is being shown when i use rpm -qa glib...How should i update my database now ...? ...

CentOS x86_64, i cant compile from sources

i have installed an IDS (Sguil), and the sensor part of the system is installed on Centos 5.1 x86_64 using a Sun XFire 4400...the problem is that i want to change a snort 2.8.0.1 compiled from srcRPM because i can't tuning the snort.conf very well, some changes affect the network cards on boot, don' ...

How can I revert back to CentOS default yum RPM Repositories

A while back I had to install an extra yum rpm repository to my CentOS 5 server as I needed newer versions of httpd (v2.2. and php (v5.1.6) than were in the default repositories at the time.I now wish to revert back to the standard repositories, I have removed reference to the custom repository from ...

Trying to compile gtk+ but no success cause glib. Can anybody help?

I am trying to actually compile glade3-3.4 so I need to compile loads of other things including glib and gtk+. I have compiled and installed glib-2.14.0 and then trying to configure gtk+.But it says-Code: ...

Trying to compile from source after RPM install?!?

HiPlease bear with me as I'm a relative newbie to PHP and source building in general. So, I've got this NMS system called JFFNMS installed...it requires many different packages which I've installed all from RPM, including PHP from RPM. Now, I need to patch PHP to support SNMPv2, so I've downloaded t ...

Ubuntu Unable to Compile Code Using Glib

I'm trying to compile some code (https://sourceforge.net/projects/arccc/), which uses Glib. I have the libglib2.0-dev package installed, but running ./configure reports that Glib is not installed. Is the autoconfig script wrong or out of date, or do I need something else installed? ...

Ubuntu Error with GLIB/irssi compile

I just compiled GLIB 2.21.2 without any trouble and then proceeded to install irssi 0.8.13 and I get this error:checking for GLIB - version >= 2.6.0... *** 'pkg-config --modversion glib-2.0' returned 2.21.2, but GLIB (2.16.3)*** was found! If pkg-config was correct, then it is best*** to remove t ...

Ubuntu Cannot compile against GLib or Gtk+

It seems there are lots of problems with updating Gtk-Gnutella.I have another, related, one.ERROR: Cannot compile against GLib.ERROR: Cannot compile against Gtk+.I've searched thru the posts here and tried every fix mentioned, downloaded libraries, incl libxml2 (http://www.xmlsoft.org/) to compile G ...

Ubuntu dbus-glib-0.71 compile error

I'm trying to compile dbus-glib-0.71 on ubuntu 6.06 runnig xgl-gnome-compizI have intel p2.4 ~750 ram... kernel 2.6.15-23-386..tried an older version but getting the same resoultI'm getting the following error:DBUS_TOP_BUILDDIR=.. dbus-send --system --print-reply=literal --dest=org.freedesktop.DBus ...

Ubuntu compile error with applications which require glib

I get this message when I try to compile a program which require Glib:checking for pkg-config... /usr/bin/pkg-configchecking for glib-2.0 gthread-2.0 gtk+-2.0 libgnomeui-2.0 libnjb... Package libgnomeui-2.0 was not found in the pkg-config search path.Perhaps you should add the directory containing ` ...

Ubuntu Cross compile for 32 bit, missing libdbus-glib-1.so

I'm cross-compiling an application to 32 bit arch. My app uses dbus-glib bindings. My base system is Ubuntu Hardy 64, so I use the -m32 flag with gcc to compile but it gives me an error of missing libdbus-glib-1.so. All other libs are present as I've already installed gcc-multilib, ia32libs etc pack ...

cross-compile(on ubuntu for win32) glib gnet application

I never met with cross-compile before. I need some glib/gnet application to be compiled for win32.I've encountered with following problems:1) first of all I need win32 versions of glibTo do that I got src from here: http://www.gtk.org/download-windows.html and was guided by http://library.gnome.org/ ...

Ubuntu glib version confusion when trying to compile atk (for gimp)

am trying to compile the gimp under ubuntu 9 (frustratingly i had all this compiling a while back)got the source (2.6.7), went on to get others:-atk-1.27.90 gegl-0.1.0 gtk+-2.16.6 pango-1.24.5babl-0.1.0 gimp-2.6.7 glib-2.20.5 intltool-0.40.6./configure, make, make install in each.. However on gettin ...